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MS Excel Training
Topics
• Launching Excel

• Excel terminology

• Understanding the ribbon

• Understanding the workbook

• Creating your first workbook

• Auto Fill

• FlashFill

• Copy data from One sheet to another

• Freeze Pane

• Sorting 

• Filtering



Launching Excel
To launch Excel

Go to your laptop’s search bar and type Excel ->

And select the Blank workbook



Excel Terminology
A good knowledge of the terminology and keywords used in MS Excel are essential in order to master the application. Some common terms are 
listed in Table below.

Terminology Description

Workbook A spreadsheet design file created in Excel is called a Workbook. It can contain one or many Worksheets or sheets.

Worksheet A Worksheet is an individual spreadsheet in a workbook. One workbook can contain multiple worksheets.

XLS/XLSX
Depending on the contents of the workbook, it is saved with different extensions, the most commonly used are XLS/XLSX. XLS is the default
file format from Excel 97-2003 and XLSX is the default formal for Excel 2007 and later.

Data Data is anything that is entered on the spreadsheet. It can be a number, text, or an image.

Rows/Columns
The data in Excel sheet is stored in row and column format. Rows are horizontal and columns are vertical. Each row is assigned a number and
each column is assigned an alphabet.

Cell The data is entered on a cell, which is an intersection of a row and column.

Cell reference 
/address

A cell reference or cell address is a combination of row (number) and column (letter) that identifies the position of a cell on a spreadsheet.

Formula
Formula or calculations use the built-in functions in Excel and are used to perform computations such mathematical, string, logical, etc. A
formula always starts with an = sign.

Pivot table A Pivot table is used to summarize the data present in the spreadsheet.

Pivot charts The graphical representation of the summarized data is done by using charts.

Sort Arranging the data based on the value or the data type.

Filter A Filter is used to display the data based on the specified criteria.



Understanding the ribbon
The Microsoft Excel ribbon enables users to execute commands to perform desired tasks. It is divided into the following:

• Tabs. The Ribbon consists of various tabs such as File, Home, Insert etc. 

• Groups. Each tab contains multiple Groups which are sets of related commands. 

• Action buttons. Groups contain action buttons/icons to execute a command. 

• More Group options. A small downward arrow at the bottom right of each group launches more options provided in the 
group. 



Understanding the workbook
In an MS Excel Workbook, the data is entered on a Worksheet, also referred to as Sheet or spreadsheet. A workbook can 
contain multiple sheets.
The structure and important components of a workbook are shown below.

Important concepts:
1. Rows
2. Columns
3. Cell
4. Cell Address
5. Formula bar
6. Sheet
7. New Sheet
8. Status bar
9. Zoom



Creating your first workbook
Excel is all about entering data and formulas in the spreadsheet. 

Using the knowledge gained in the previous sections, create your first workbook.

Tip : Enter each data item in a single cell.

Refer to the enclosed / Instructor provided data sheet and type the first 3 rows of data. 

The first row is the header row and rest is the data pertaining to the header. (See the screen shot below)



Auto Fill
Instead of typing the data in all the rows/cells, use the Auto Fill option to enter data more easily. 

Auto fill works on cells having a pattern for example, Row ID and Order Date. Row ID column contains consecutive numbers 1,2,3,4 and 

Order Date contains the first date of every month. Auto-fill cannot be used on Ship Date as it does not have any pattern. 

Steps to use the Auto fill feature:

1. In the worksheet, select the Row ID values 1,2 and use the plus (+) sign on the edge of the cell and drag it down.

This will fill the remaining Row IDs on the rows below.

2. Order Date column has a pattern i.e., it contains the first day of every month. The Auto fill can be used on this column too. Select 
the first two dates on this column and drag it down. Use autofill to enter/fill dates till 12/1/2021.

Tip: To create consecutive dates by using Autofill, select the
first date value to auto fill the rest of the cells. 



Flash Fill
Flash fill is a new feature of Excel 2023. It is similar to autofill, but automatically fills the data in the cells when it identifies a pattern. 

For example, Flash fill can be used to separate the first and second names from a single column or combine the first and second names from 
two different columns.

Exercise: Currently Ship Mode contains two words, for example, ‘Priority Delivery’; the objective is to separate these values into two columns.

Steps to use the Flash fill feature:

1. In the worksheet created previously, insert two blank columns after the Ship Mode column. Highlight Column E, right-click and select 
Insert. Repeat the step. This will insert two blank columns after Ship Mode. 

2. Provide the headers of these new columns as Ship Name1 and Ship Name2. 

3. On Ship Name 1 column, type the first name ‘Priority’ in the first cell. 

4. Use the right-click of the mouse and drag down from the edge of the cell and select Flash Fill. It will fill in the corresponding Ship Name1.



Flash Fill Contd.
5. Similarly, on the Ship Name2 column, type the second name ‘Delivery’ in the first cell. Use the right-click of the mouse and drag 

down from the edge of the cell and select Flash Fill. It will fill in the corresponding Ship Name2.

6. To combine the columns again, insert a column after Ship Name2. Name this column header as Ship Mode Combined. 

7. On the first cell, type the combined name of the first Ship Mode – ‘Priority Delivery’.  Use the right-click of the mouse and drag 
down from the edge of the cell and select Flash Fill. It will fill in the corresponding combined Ship Modes.



Copy data from one sheet to another
Sometimes data need to be copied from one sheet to another or we need to create the copy of the existing sheet.

Steps to copy the data:

1. On the sheet, click on any cell and press Ctrl + A on the keyboard to select entire data on the sheet. Press Ctrl + C to copy the selected 
data. 

2. Create a new sheet by clicking on the + sign next to the existing sheet name at the left bottom. Click on the first cell i.e. A1 and press 
Ctrl + V on the keyboard to paste the copied data.

3. Renaming the sheets. Right now, the new sheet will have the name as Sheet2. Rename the sheet by right-clicking on it and selecting 
Rename. 

Rename the sheet as Copy_Original or any desired name.

The option Move or Copy as shown in the Figure is used to move or copy the spreadsheet in the existing Workbook. Try this option and 
observe the results.

Save your workbook. Create a folder MS Excel training and save the file.



Freeze Pane
The Freeze pane option keeps the area of the worksheet visible while scrolling vertically or horizontally. 

This option is available on the View tab of the ribbon under the Window group.

Exercise. Apply Freeze pane on the worksheet so that when user scrolls, the header row and the first column are always visible.

The current spread sheet contains multiple rows of data. If vertical scroll is used, the header gets hidden and if horizontal scroll is 
used the first column gets hidden. This can be fixed by using the Freeze pane. 

Steps to use Freeze pane:
1. Freezing the header row. From the spreadsheet, navigate to View tab and 
select Freeze Panes and then select Freeze Top Row.
2. Freeze first column. 
From View/Freeze panes, select Freeze First Column. When horizontal scroll is used, 
the first column will always be visible.
3.Freeze multiple rows. 
Navigate to View/Freeze panes and select Unfreeze pane to reset the earlier option. 
Now select the second row and first cell i.e., A3. Navigate to View/Freeze Panes and select Freeze 
Panes. This will lock the first two rows from the top.
4. Freezing both Rows and Columns. 
Select a cell below the header row and right of the first column, i.e., B3. 
Navigate to View/Freeze Panes and select Freeze Panes. This will lock the row and column together.
Freeze panes option is useful when the worksheet contains huge amounts of data. 



Sorting
Sorting is the process of arranging a group of data in a particular order. In Excel, sorting can be performed on:
• The text field (Alphabetical sorting), numbers (ascending or descending). 
• Dates (oldest to newest and vice versa). 
• Format (based on colors). 
• Sorting can be performed on a single column or multiple columns.
Sorting options are available in the Home tab under Editing group or from the Data tab under 
Sort & Filter group. 

Exercise. In the previously created workbook, sort the data first by A to Z of Ship mode, then by Segment (Z to A) and then by Region (A-Z).
Steps to perform Sorting using multiple columns:
1. Navigate to Data tab in the ribbon and select Sort. 
2. A Sort dialog box will pop up with different options: 
• Sort By: Select Ship Mode from the dropdown to specify on which column the 
sorting will occur. 
• Sort On: Select Cell Values to specify how the sorting will be performed i.e., 
on the Cell Values 
or Color.
• Order: Select A to Z to specify the sort order i.e., ascending or descending. 
• In this option, Custom List is used to specify the user-defined sorting pattern.



Filtering of data
Filters display the data based on a given criteria. Filters control what data is to be displayed and what data is to be excluded. 

Filters can be applied from the Home tab under Editing group or from the Data tab under Sort & Filter group. 

Filters can be functional on a text column or on a numeric column. Both provide different options. To display filtered data, use the selections from 
the list, search for the values, or use comparison options from Text or Number filters. 



Filtering of data - Exercise
Exercise. In the Excel file, Filter the data as mentioned below 
-Ship mode as First class and then look for the data where Sales > 100.

Steps to apply Filters on the data:
1. Select any header column on the worksheet. Navigate to Data tab in the ribbon and select Filter. 
This will display drop-down arrows on each header column.
2. On the Ship Mode column, use the drop-down arrow. 
Uncheck Select All and select First Class from the list of Ship Mode values.
This will filter the data by Ship Mode = First Class. 
3. To apply filter for Sales > 100, perform the following two steps: 
From the Sales column drop-down, select Number Filters, then choose Greater Than.
In the subsequent Custom Autofilter dialog specify the condition.



Enhance your Excel knowledge

Enhance your Excel Knowledge by exploring the book:

Excel Basics to Advanced

Excel Blogs

Take instructor-led training

https://www.amazon.com/Excel-Basics-Advanced-Applications-Calculations/dp/0999244965/ref=sr_1_2?crid=37GHDSVILEOCP&dib=eyJ2IjoiMSJ9.1qeWrLH3vciX-uj4G0i-vHxgE4xdQcnl_jVwXeWGdn1EP0GYdfzk5Lo1UhdNpHJ-w8el9BcrPuFPcYxv6uYgtHq_WpUR_HgTpjl9DElGKJcUQYXMWo15etWyW5CltzvCHjnC_JcdR5zlE07U4F2boe-sMhBu8RieN-yu3vP3NRYrYZBcDprXBJZO04lGXZvs.2htqoyq5UsNGUhrY2jb4sxSYERSacyPmjc4V1bMuYcM&dib_tag=se&keywords=chandraish+sinha&qid=1708377494&sprefix=%2Caps%2C180&sr=8-2
https://ohiocomputeracademy.com/category/msexcel/
https://ohiocomputeracademy.com/contact/
https://www.amazon.com/Excel-Basics-Advanced-Applications-Calculations/dp/0999244965/ref=sr_1_2?crid=37GHDSVILEOCP&dib=eyJ2IjoiMSJ9.1qeWrLH3vciX-uj4G0i-vHxgE4xdQcnl_jVwXeWGdn1EP0GYdfzk5Lo1UhdNpHJ-w8el9BcrPuFPcYxv6uYgtHq_WpUR_HgTpjl9DElGKJcUQYXMWo15etWyW5CltzvCHjnC_JcdR5zlE07U4F2boe-sMhBu8RieN-yu3vP3NRYrYZBcDprXBJZO04lGXZvs.2htqoyq5UsNGUhrY2jb4sxSYERSacyPmjc4V1bMuYcM&dib_tag=se&keywords=chandraish+sinha&qid=1708377494&sprefix=%2Caps%2C180&sr=8-2
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